快三彩票开户

您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

分時主圖指標公式[通達信公式]

相關標簽: 分時t0買賣點主圖指標 、 分時買賣點主圖指標 、 分時量指標主圖公式 、 分時圖買賣點指標公式 、 分時t十0主圖指標公式 、 通達信分時漲停主圖源碼 、 精準分時主圖指標公式 、 分時主圖買點指標源碼 、 通達信超準分時指標圖 、 分時指標公式源碼 、 通達信手機分時指標 、 波段分時主圖指標公式源碼 、

?

1、運用了L2行情函數,本公式需要L2數據支持,不同于有些不用L2行情函數也能編出“資金流向”的公式。

2、因軟件數據非全推方式,盤中可能造成軟件運行慢的問題,盤后需要下載數據
以下為源碼:被引用一
VOL0:L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1);
VOL1:REF(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),1);
VOL2:REF(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),2);
VOL3:REF(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),3);
VOL4:REF(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),4);
VOL5:REF(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),5);
VOL6:REF(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),6);
VOL7:REF(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),7);
VOL8:REF(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),8);
VOL9:REF(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),9);
VOL10:LARGEINTRDVOL-LARGEOUTTRDVOL;
VOL11:REF(LARGEINTRDVOL-LARGEOUTTRDVOL,1);
VOL12:REF(LARGEINTRDVOL-LARGEOUTTRDVOL,2);
VOL13:REF(LARGEINTRDVOL-LARGEOUTTRDVOL,3);
VOL14:REF(LARGEINTRDVOL-LARGEOUTTRDVOL,4);
MAXV:HHV(L2_VOL(0,0)+L2_VOL(1,0)+L2_VOL(2,0)-L2_VOL(0,1)-L2_VOL(1,1)-L2_VOL(2,1),10);
MAXW:HHV(LARGEINTRDVOL-LARGEOUTTRDVOL,5);
R0:CLOSE>OPEN;
R1:REF(CLOSE,1)>REF(OPEN,1);
R2:REF(CLOSE,2)>REF(OPEN,2);
R3:REF(CLOSE,3)>REF(OPEN,3);
R4:REF(CLOSE,4)>REF(OPEN,4);
R5:REF(CLOSE,5)>REF(OPEN,5);
R6:REF(CLOSE,6)>REF(OPEN,6);
R7:REF(CLOSE,7)>REF(OPEN,7);
R8:REF(CLOSE,8)>REF(OPEN,8);
R9:REF(CLOSE,9)>REF(OPEN,9);
R10:LARGEINTRDVOL>LARGEOUTTRDVOL;
R11:REF(LARGEINTRDVOL,1)>REF(LARGEOUTTRDVOL,1);
R12:REF(LARGEINTRDVOL,2)>REF(LARGEOUTTRDVOL,2);
R13:REF(LARGEINTRDVOL,3)>REF(LARGEOUTTRDVOL,3);
R14:REF(LARGEINTRDVOL,4)>REF(LARGEOUTTRDVOL,4);
分時決策
M0:=被引用一.VOL0#DAY;
M1:=被引用一.VOL1#DAY;
M2:=被引用一.VOL2#DAY;
M3:=被引用一.VOL3#DAY;
M4:=被引用一.VOL4#DAY;
M5:=被引用一.VOL5#DAY;
M6:=被引用一.VOL6#DAY;
M7:=被引用一.VOL7#DAY;
M8:=被引用一.VOL8#DAY;
M9:=被引用一.VOL9#DAY;
M10:=被引用一.VOL10#DAY;
M11:=被引用一.VOL11#DAY;
M12:=被引用一.VOL12#DAY;
M13:=被引用一.VOL13#DAY;
M14:=被引用一.VOL14#DAY;MAXV:=被引用一.MAXV#DAY;
MAXW:=被引用一.MAXW#DAY;R0:=被引用一.R0#DAY;
R1:=被引用一.R1#DAY;
R2:=被引用一.R2#DAY;
R3:=被引用一.R3#DAY;
R4:=被引用一.R4#DAY;
R5:=被引用一.R5#DAY;
R6:=被引用一.R6#DAY;
R7:=被引用一.R7#DAY;
R8:=被引用一.R8#DAY;
R9:=被引用一.R9#DAY;
R10:=被引用一.R10#DAY;
R11:=被引用一.R11#DAY;
R12:=被引用一.R12#DAY;
R13:=被引用一.R13#DAY;
R14:=被引用一.R14#DAY;
DRAWRECTREL(180,CONST(1000-(M0*500/MAXV)),195,1000,IF(R0,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(180,CONST(1000-(M10*150/MAXW)),195,1000,IF(R10,RGB(200,0,200),RGB(80,0,255)));DRAWRECTREL(160,CONST(1000-(M1*500/MAXV)),175,1000,IF(R1,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(160,CONST(1000-(M11*150/MAXW)),175,1000,IF(R11,RGB(200,0,200),RGB(80,0,255)));DRAWRECTREL(140,CONST(1000-(M2*500/MAXV)),155,1000,IF(R2,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(140,CONST(1000-(M12*150/MAXW)),155,1000,IF(R12,RGB(200,0,200),RGB(80,0,255)));DRAWRECTREL(120,CONST(1000-(M3*500/MAXV)),135,1000,IF(R3,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(120,CONST(1000-(M13*150/MAXW)),135,1000,IF(R13,RGB(200,0,200),RGB(80,0,255)));DRAWRECTREL(100,CONST(1000-(M4*500/MAXV)),115,1000,IF(R4,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(100,CONST(1000-(M14*150/MAXW)),115,1000,IF(R14,RGB(200,0,200),RGB(80,0,255)));DRAWRECTREL(80,CONST(1000-(M5*500/MAXV)),95,1000,IF(R5,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(60,CONST(1000-(M6*500/MAXV)),75,1000,IF(R6,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(40,CONST(1000-(M7*500/MAXV)),55,1000,IF(R7,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(20,CONST(1000-(M8*500/MAXV)),35,1000,IF(R8,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(0,CONST(1000-(M9*500/MAXV)),15,1000,IF(R9,RGB(100,0,0),RGB(0,50,0)));DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0035,1,0,'十'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0235,1,0,'九'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0435,1,0,'八'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0635,1,0,'七'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0835,1,0,'六'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1035,1,0,'五'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1235,1,0,'四'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1435,1,0,'三'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1635,1,0,'二'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1835,0.95,0,'今'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1835,1,0,'天'),COLORWHITE;分時均價線:SUM(C*V,240)/SUM(V,240),COLORBROWN;
MD:=EMA(C,1)-EMA(C,5);
STICKLINE(MD>0,DYNAINFO(3),DYNAINFO(3)+MD*2,0,1),COLOR5151A2;
STICKLINE(MD<=0,DYNAINFO(3),DYNAINFO(3)+MD*2,0,1),COLOR74743A;
分時線:CLOSE,COLORCYAN;
上升:IF(CLOSE>=REF(CLOSE,1),CLOSE,DRAWNULL),COLOR0000C6;

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

快三彩票开户有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容